Where can I change my external IP adres because the Silo Node gets it wroung. Or ad my DDNS adres instead off the IP. I run tailscale also for other use but must be no problem. For some reason I get a completely other extern IP adres for some reason.
When following the setup instructions from Step-by-Step Instructions to Install Silo Node Using Docker | Silo Docs, you add a DDNS domain at -e ADDRESS=“domain.ddns.net:28967”.
Thanks and I did update the adress to DDNS server, ports open. Still I get red dot > offline.
2026-04-23T08:35:35Z ERROR contact:service ping orbital failed {“process”: “storagenode”, “orbital_id”: “1dkRxqhU46NfjV1xJZrxnt8RwWGK2u…Zoj4s8HVVK4”, “attempts”: 6, “error”: “ping orbital: failed to ping storage node, your node indicated error code: 0, rpc: tcp connector failed: rpc: tls peer certificate verification: not signed by any CA in the whitelist: CA cert”, “errorVerbose”: “ping orbital: failed to ping storage node, your node indicated error code: 0, rpc: tcp connector failed: rpc: tls peer certificate verification: not signed by any CA in the whitelist: CA cert\n\tsilos3.com/silo/storagenode/contact.(*Service).pingOrbitalOnce:232\n\tsilos3.com/silo/storagenode/contact.(*Service).pingOrbital:169\n\tsilos3.com/silo/storagenode/contact.(*Chore).updateCycles.func1:89\n\tsilos3.com/common/sync2.(*Cycle).Run:102\n\tsilos3.com/common/sync2.(*Cycle).Start.func1:77\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:93”}
I have forwarded port 28967 in a sinlge rule as both TCP/UDP traffic.
Router does not allow 2 rules whit same port number.
Please follow all the instructions provided in the Silo Docs. Step-by-Step Instructions to Install Silo Node Using Docker | Silo Docs
you miss command ./trustkey.exe authorize silonode <email:your-authorization-token>
Get an Authorization Token
-
Open Silo registration page on the Silo website.
-
Enter your email to generate an authorization token.
-
Save this token securely, as it will be used to authenticate your node.
Authorize the Trustkey:
Copy
./trustkey.exe authorize silonode <email:your-authorization-token>
Replace <email:your-authorization-token> to authorization token
![]()
This is what I get after the command
Did check the port and that is open still.
I did delete the docker image and file on storage disk, only left the CA key folder.
And did rebuild the docker image again.
Use Trustkey https://github.com/silos3/silo-release/releases/download/v1.0.0-P/trustkey_windows_amd64.exe.zip
I did use that link and did do a full new setup. Did got some errors but the Node was build.
Now it want me to register and stake again 20k LRS. Why does it not see at my wallet that I did already stake 20K few days ago. Haw can I do 100% fresh install and setup a working Silo Node…? Thanks
I did delete the new setup and got my backup running and no registration to do, its the old Node.
Now when I use the given command above I get this:
Do I need to delete some files and start over whit new fresh install?
keep the keys from the node you staked on backed up safe somewhere, can do reinstall’s but add them keys to get staked node back
does your router have tcp,udp,both ? for port 28967
if no do tcp 28967
udp 28967 2 seperate but different
Thanks, I did safe them after first setup.
But I like to know where all the old files are to get a fresh install done? Still see v1.1.1
try ’ geek uninstaller ’ maybe
@SkyFall please delete file trustkey_windows_amd64.exe and trustkey_windows_amd64.exe.zip and trustkey.exe
Both types of protocol must be open and forward.
any idea how to fix this>> 2026-04-25T06:33:54Z ERROR orders failed to settle orders for orbital {“process”: “storagenode”, “orbital_id”: “xxxxxxxxxxxxxxxxxxxxxxxxxEDITEDxxxxxxxxxxxxxxxxxxxxxx”, “orbital_id”: “xxxxxxxxxxxxxxxxxxxxxxxxxEDITEDxxxxxxxxxxxxxxxxxxxxxxxxx”, “error”: “order: failed to start settlement: rpc: tcp connector failed: rpc: tls peer certificate verification: not signed by any CA in the whitelist: CA cert”, “errorVerbose”: “order: failed to start settlement: rpc: tcp connector failed: rpc: tls peer certificate verification: not signed by any CA in the whitelist: CA cert\n\tsilos3.com/silo/storagenode/orders.(*Service).settleWindow:264\n\tsilos3.com/silo/storagenode/orders.(*Service).SendOrders.func2:219\n\tgolang.org/x/sync/errgroup.(*Group).Go.func1:93”}
No, can only do TCP/UDP as both in one rule.
Router does not allow to set 2 same ports as one tcp and one udp. It’s fully own controlled TP-Link Omada network and have no modem/router provider.
Thanks! I did setup like All and ports must be fine.
Next will be to remove the old 1.1.1 version and rebuild the Node.


